PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Verlängertes Zertifikat importieren



Ipsi
13.11.2009, 16:36
Benötige dringend Hilfe:
Habe von Elster Mail erhalten, dass Zertifikat am 07.12.09 abläuft, wenn ich nicht das verlängerte Zertifikat importiere.
Da ich das Z. verlängern möchte, habe ich die vorgegebenen Schritte verfolgt und bin bis zu dem Punkt gekommen, wo als "Überschrift"
Verlängertes Zertifikat importieren - steht
Fenster für Pfad von .PFX-Datei bereitgestellt wird und
Fenster PIN (6 Zeichen)
Problem: Die PIN könnte ich eingeben
in das Fenster um den Pfad für die PFX-Datei einzugeben, komme ich nicht rein. Alles probiert!

Wer kann helfen, was kann ich tun.
Vielen Dank und Grüße
IPSI

V. Liersee
16.11.2009, 07:18
Welches Betriebssystem nutzen Sie, welche Java-Version? Bei Java ist die 17 aktuell, die vorhergehenden 15 und 16 weisen im Zusammenhang mit Elster Fehler auf.

Ipsi
16.11.2009, 12:29
sooooooooo schnell und soooooooo super. Vielen, vielen Dank.
Habe auf Java 6 (1.7) aktualisiert und siehe da...es funktionierte.
Statt "Elias" mit Wackelkopf, sollte hier besser V.Liersee veröffentlicht werden.
Nochmals vielen Dank für Ihre Hilfe und hoffentlich nicht bis zum nächsten Mal.
IPSI

AchimPeters
13.03.2010, 00:40
Welches Betriebssystem nutzen Sie, welche Java-Version? Bei Java ist die 17 aktuell, die vorhergehenden 15 und 16 weisen im Zusammenhang mit Elster Fehler auf.

Habe das gleiche Problem wie der OP mit Sun-JRE 6.0_18 (XP SP3, Firefox 3.6). Das Feld "Pfad der .pfx-Datei" bei "Verlängertes Zertifikat importieren" ist leer (weiß), es gibt keinen Button "Durchsuchen" und ich kann nichts eingeben (der Cursor lässt sich weder mit Maus noch mit TAB in das Feld bewegen).

Bei JRE 6.0_17 ging bei mir schon das Logon nicht (2 Fehlermeldungen bezgl Plugin Es genüge nicht den Sicherheitsrichtlinien a) All-xxxx(?) fehle in den Sicherheitseinstellungen, b) es wäre kein Plugin installiert).

Nach Fehlerbehebung will ich ja gar nicht fragen, ein quick&dirty-Workaround wäre ja schon was ...

Gruß
Achim

AG1971
13.03.2010, 01:06
Ich nutze Win7 mit Firefox 3.6 und JAVA 6 Update 18 und habe keine Probleme mit dem Einloggen.

Das gleiche gilt mit VISTA SP2 und Win XP SP3 und den o.g. Komponenten.

Bild 1: https://www.elster.de/anwenderforum/album.php?albumid=10&pictureid=24

Bild 2: http://www.elster.de/anwenderforum/picture.php?albumid=10&pictureid=26

Bild 3: http://www.elster.de/anwenderforum/picture.php?albumid=10&pictureid=25

Bild 4: http://www.elster.de/anwenderforum/picture.php?albumid=10&pictureid=58

Bild 5: http://www.elster.de/anwenderforum/picture.php?albumid=10&pictureid=56

http://www.java.com/de/

Installationshinweise: http://www.java.com/de/download/help/firefox_online_install.xml

AchimPeters
13.03.2010, 13:49
Mit dem 18er habe ich auch keine Probleme beim Einloggen (das war bei 6.0_17). Ich habe, wie ich schrieb, mit 6.0_18 Probleme beim Verlängern des Zertifikats und zwar an der Stelle
"Verlängertes Zertifikat importieren".

AG1971
13.03.2010, 14:37
Nur für mein Verständis gefragt:

1. Du gehst also mit dem Firefox 3.6 auf die Seite https://www.elsteronline.de/eportal/

2. Du wählst dann um in das Portal zu kommen den Punkt Software-Zert. / Login

3. im nachfolgenden Fenster kannst Du noch den Pfad zu Deiner bisherigen PFX-Datei mit der Schaltfläche ´Durchsuchen´ anwählen und den PIN eingeben

4. Du gelangst dann in Deinen persönlichen Bereich des ElsterOnlinePortals

Und ab hier beginnt dann das Problem mit "Verlängertes Zertifikat importieren" ?
Was sind dort Deine Schritte ?

AchimPeters
14.03.2010, 01:17
Sorry, will antworten aber lange Postings geben Bad Request

AG1971
14.03.2010, 13:22
Ja, Bad Request gibt es hier im Forum, wenn Du bestimme Zeichen in Deinem Text verwendest.

2x - direkt hintereinander geht z.B. nicht usw. usw.

AchimPeters
14.03.2010, 22:53
Nach langem Suche: Ich bekomme den Bad-Request, wenn ich doppelte Anführungszeichen (Shift-2) im Text habe. Was mich wundert: Du hattest auch welche um Verlängertest Zertifikat importieren und konntest die posten. Wenn ich die quote, gibt es Bad Request.


Nur für mein Verständis gefragt:

1. Du gehst also mit dem Firefox 3.6 auf die Seite https://www.elsteronline.de/eportal/

2. Du wählst dann um in das Portal zu kommen den Punkt Software-Zert. / Login

3. im nachfolgenden Fenster kannst Du noch den Pfad zu Deiner bisherigen PFX-Datei mit der Schaltfläche Durchsuchen anwählen und den PIN eingeben

4. Du gelangst dann in Deinen persönlichen Bereich des ElsterOnlinePortals


Richtig.



Und ab hier beginnt dann das Problem mit Verlängertes Zertifikat importieren?


Kurz darauf. Ich war zuvor per E-Mail darauf hingewiesen worden, dass mein Zertifikat bald abliefe und ich solle es verlängern. Nach dem Login erschien auch ein Button oder Link mit Verlängern. Mittlerweile erscheint der nicht mehr, weil die Verlängerung inzwischen geklappt hat.

Ich hatte irgendwo für ein anderes Problem gelesen, man solle in den Java-Settings die temporären Internet-Dateien löschen (Windows-Speak für gecachte Jars). Ich hatte aber ob früherer Probleme das Cachen sowieso ausgeschaltet. Das habe ich dann mal eingeschaltet, und dann ging es auch mit dem Verlängern. Dass es aber am Einschalten des Cachings gelegen haben solle, will mir nun gar nicht einleuchten (bin Informatiker).




Was sind dort Deine Schritte ?


Um Deine Frage zu beantworten: Als ich das Problem noch hatte, kam das Fenster mit dem Verlängertes Zertifikat importieren, nachdem ich auf den Verlängern-Link geklickt hatte.

Danke für Deine Hilfe.

Bye
Achim

AG1971
14.03.2010, 23:04
Tja, ich bin froh, dass es bei Dir nun geklappt hat.
Und wieder etwas gelernt.